Motor cutting out on acceleration

Here is the place to ask questions about working on your 650.

Moderator: BRP

bikeboy
Posts: 9
Joined: Mon Apr 28, 2014 3:34 pm

Motor cutting out on acceleration

Postby bikeboy » Sat Mar 12, 2016 12:02 am

I did a 300 mile ride today, and 2 miles from home, when I pull the throttle hard to accelerate, the motor will jerk ahead, and quickly decal. bring throttle back and is OK and run normal, wont stall, I do it again, and symptoms repeat. Seems it's not getting fuel or ignition. maybe a fuel pump or clogged tank screen? If run easy, it seems to run OK till I got home. I bought a Harbor freight fuel pump tester, but don't know how to install in line. I could check pump output and flow rate w/ clamp, but not in line between pump and throttle body w/o cutting hose.
Please help;
HR...
bikeboy
Posts: 9
Joined: Mon Apr 28, 2014 3:34 pm

Re: Motor cutting out on acceleration

Postby bikeboy » Sat Mar 12, 2016 12:36 am

[quote="bikeboy"

]07 ninja 650R
I did a 300 mile ride today, and 2 miles from home, when I pull the throttle hard to accelerate, the motor will jerk ahead, and quickly decal. bring throttle back and is OK and run normal, wont stall, I do it again, and symptoms repeat. Seems it's not getting fuel or ignition. maybe a fuel pump or clogged tank screen? If run easy, it seems to run OK till I got home. I bought a Harbor freight fuel pump tester to test pressure and flow rate ignition on, and running checking specs. Please help; Thanks;
HR...[/quote]
bikeboy
Posts: 9
Joined: Mon Apr 28, 2014 3:34 pm

Re: Motor cutting out on acceleration

Postby bikeboy » Sat Mar 12, 2016 8:27 pm

Well; just tested fuel pressure and flow rate. ignition on: 43-44 lbs. will not hold for 30 sec. drops gradually to 30. Idling pressure is steady at 43-44 lbs. The flow rate is perfect. 60ml for 3 sec. The pressure is supposed to be @ 48psi, pump stopped-38psi for 30 sec. and idling @ 48 psi. All #'s are low, even when revved and hold throttle open, but flow rate is OK. Guess I'll pull pump assembly to inspect. HR...
steigs84
Posts: 117
Joined: Thu Oct 02, 2008 2:17 am
Location: Fort Worth, TX

Re: Motor cutting out on acceleration

Postby steigs84 » Sat Jul 30, 2016 2:47 pm

Sorry for not reading often, but I'm do believe you found it.

Return to “Tech”

Who is online

Users browsing this forum: No registered users and 3 guests