bike won't rev past 9000

Here is the place to ask questions about working on your 650.

Moderator: BRP

riversbikes
Posts: 66
Joined: Tue Jun 15, 2010 9:09 pm

bike won't rev past 9000

Postby riversbikes » Mon Apr 25, 2011 10:31 pm

Hey all, have a 2007 ex650r racebike. muzzy full system with their recommended map, performance air filter, got rid of the smog stuff as per this forum, and also drilled holes in the airbox as per gary's instructions. Had it out to the track this past weekend, and it wouldn't rev past 9000 rpm. My buddy has the identical bike (2006) with the same pipe and map, but no airbox mods. His bike revs to the redline in every gear, while mine won't in any gear. Still a fun ride, but there is something wrong with my machine... any ideas? No trouble light comes on... likely needs to be set up on a dyno with the airbox mods, but it should still rev past 9000, right? My buddy's bike is also faster, and he's heavier, with the same gearing. I notice that when I remove my race gas cap, there is considerable air pressure noises coming in/out as I loosen the cap -- some sort of vapour-lock happening? Perhaps some vent tubes blocked in the tank, starving the engine of fuel at high rpm? Willing to try anything as a starting point. Otherwise the bike seems to run OK. Yes, I checked the trottle, it winds the butterfly to the stop...
james
lurch
Posts: 41
Joined: Mon Dec 21, 2009 2:12 am
Location: Australia

Re: bike won't rev past 9000

Postby lurch » Tue Apr 26, 2011 2:11 am

Can't remember what the Ninja/ER6 has but my Speed Triple has two hoses that attach under the tank (other than the main fuel line). One has a non-return valve and if you put it in the wrong spot it won't let the tank breathe which causes a vacuum.

Failing that try a different map, when I first put the PC3 on the ER6 I tried a few different maps and noticed it didn't seem to want to rev with a couple.
User avatar
BRP
Posts: 1925
Joined: Sat Sep 27, 2008 1:37 pm
Location: Southport, North Carolina

Re: bike won't rev past 9000

Postby BRP » Tue Apr 26, 2011 8:56 am

I no long have a Cali tank, so I can't check the routing.
I know they are all color coded under the tank.
The canister lines just need to be looped.
I would 1st check that. If ok, I would try a different fuel pump.
riversbikes
Posts: 66
Joined: Tue Jun 15, 2010 9:09 pm

Re: bike won't rev past 9000

Postby riversbikes » Tue Apr 26, 2011 4:09 pm

its not a cali bike (at least I don;t think so ) bought it at crashedtoys in MN. Thanks for the advice -- will check the hose first for proper venting, then the pump. Also compared maps -- the muzzy map has negative numbers (I assume this means fuel volume???) the higher the rpm, whereas another map for a different full system, but with the airbox snorkels removed, has positive numbers the higher the rpm/throttle turn... With my opened up airbox, should I not be adding more fuel at higher rpm? I know, I should get the bike dynoed, and I plan to, but the nearest dyno is 3 hours away, and I need to deal with this rpm issue first.

james
User avatar
Addohm
Posts: 670
Joined: Thu Oct 02, 2008 8:10 am
Location: Little Rock, AR
Contact:

Re: bike won't rev past 9000

Postby Addohm » Tue Apr 26, 2011 8:04 pm

Open the gas cap, rev it past 9000.

Remove the PC, rev it past 9000.

Drive it in to a wall if it doesn't ;) :fu sign
User avatar
Retro Rocketeer
Posts: 188
Joined: Thu Apr 22, 2010 4:30 pm
Location: Boise, ID

Re: bike won't rev past 9000

Postby Retro Rocketeer » Tue Apr 26, 2011 8:35 pm

I have opened airbox, aftermarket filter, blah blah, and full Muzzy system. Mine revs to the moon. I just had mine dyno tuned and you are right, most of the duration numbers are well into the negatives. I saw the Muzzy map on the Power Commander web site. That's just characteristic of this exhaust. The previous posts make the most sense to me. As I recall, there are 3 hoses. The tank has color dots on its bottom to match up the color striped hoses. You may have a clogged, pinched, or kinked hose. The suggestion to open the gas cap is an easy test too.

Make sure you let us know when you solve the problem.
riversbikes
Posts: 66
Joined: Tue Jun 15, 2010 9:09 pm

Re: bike won't rev past 9000

Postby riversbikes » Tue Apr 26, 2011 9:22 pm

I checked and the oem vent hose was clogged solid -- no amount of pressure would clear it. changed oout the hose, made sure the tank was venting with the new one -- now need to give it a run on the street, under load. Will let you know, but it appears to be the culprit.
djrussell
Posts: 860
Joined: Tue Oct 07, 2008 2:37 am

Re: bike won't rev past 9000

Postby djrussell » Wed Apr 27, 2011 9:55 am

which hose is it exactly? it'd be nice to watch for if it happens to someone else.

the one that comes off the bottom of the tank on the left side? that's the only one i'm aware of. that should just be for draining spilled fuel away from the neck. it doesn't actually vent the tank as far as i know. someone correct me if i'm wrong. all the venting should be done by the cap.
riversbikes
Posts: 66
Joined: Tue Jun 15, 2010 9:09 pm

Re: bike won't rev past 9000

Postby riversbikes » Fri Apr 29, 2011 6:13 am

i dont have a cali tank -- my own dumbass idea had both the race cap I bought sealed to the tank with no venting, and due to the bike being crashed (not by me) and not properly inspected, the overflow vent was also blocked -- i essentially had a sealed tank. hopefully i can check soon if i fixed it
teamjock
Posts: 3
Joined: Sat Feb 04, 2012 2:40 pm

Re: bike won't rev past 9000

Postby teamjock » Sat May 11, 2013 4:40 pm

Did you solve the problem you were experiencing (wont Rev past 9000).
I ask because I am experiencing a similar problem.

Return to “Tech”

Who is online

Users browsing this forum: No registered users and 2 guests