Fuel Pump Problem

Here is the place to ask questions about working on your 650.

Moderator: BRP

Jvalov1
Posts: 18
Joined: Sun Mar 20, 2011 4:12 am
Location: California

Fuel Pump Problem

Postby Jvalov1 » Sat Aug 25, 2012 3:21 pm

I rode all around town one day and went into a store and when i came back out, my bike wouldnt start. the Fuel pump wont turn on. a week later my fuel pump turned on and i rode for 2 days and on the way home, the RPMS went lower and lower and died out again. Again, the fuel pump wont turn on.

Electrical problem?
Something Clogged?
steigs84
Posts: 117
Joined: Thu Oct 02, 2008 2:17 am
Location: Fort Worth, TX

Re: Fuel Pump Problem

Postby steigs84 » Sat Aug 25, 2012 7:33 pm

Had the exact same problem with a bad pump. I replaced the pump, it ran great for a day or so then the connection from the stator to the main harness on the left side of the motor melted down. I doubt they had anything to do with each other, I tried the old fuel pump after fixing the connection, it still didn't flow enough. Google the P/N, I found a new one for $179.
Jvalov1
Posts: 18
Joined: Sun Mar 20, 2011 4:12 am
Location: California

Re: Fuel Pump Problem

Postby Jvalov1 » Sun Aug 26, 2012 5:33 pm

So how does your new fuel pump work now? how did your wiring melt down? what is stator?
Warhound
Posts: 34
Joined: Wed Jul 25, 2012 3:32 am

Re: Fuel Pump Problem

Postby Warhound » Sun Aug 26, 2012 8:30 pm

Stator is a motorcycle equivalent to an alternator.
steigs84
Posts: 117
Joined: Thu Oct 02, 2008 2:17 am
Location: Fort Worth, TX

Re: Fuel Pump Problem

Postby steigs84 » Mon Aug 27, 2012 3:00 am

All works good now. I said I doubt the wiring had anything to do with the pump failure, but I figure I'd try the old pump after I fixed the wiring. If you look at the left side (as you sit on it) engine cover, you will see 3 wires coming out of it. Follow these 3 wires to the connector to the main harness. Pull the connector apart, if it looks like the photo I attached, you need to repair it. If it's not burnt, just put a new pump in.
You do not have the required permissions to view the files attached to this post.
tp555
Posts: 153
Joined: Thu Jan 15, 2009 6:54 am

Re: Fuel Pump Problem

Postby tp555 » Mon Aug 27, 2012 5:36 am

Thats crispy.How many miles on your bike? I had the stator crap out around 35k miles.
steigs84
Posts: 117
Joined: Thu Oct 02, 2008 2:17 am
Location: Fort Worth, TX

Re: Fuel Pump Problem

Postby steigs84 » Mon Aug 27, 2012 4:10 pm

1st fuel pump went at 8,000. Covered by Kawasaki as it was evident it was not assembled right. it was 2 years after I bought the bike. It was stored for 1.5 years when I was stationed in japan.

Stator went at 18,000

Ignition Sticks at 21,000

2nd Fuel Pump went at 31,000 or so, the Stator connection melted at the same time. But the stator was OK. Just the connection. I just cut out the connector and wired it directly. Sitting at 39,000 right now.
Jvalov1
Posts: 18
Joined: Sun Mar 20, 2011 4:12 am
Location: California

Re: Fuel Pump Problem

Postby Jvalov1 » Thu Sep 06, 2012 12:03 am

thanks, i ordered a pump last week so i'll see how it goes
User avatar
BRP
Posts: 1925
Joined: Sat Sep 27, 2008 1:37 pm
Location: Southport, North Carolina

Re: Fuel Pump Problem

Postby BRP » Fri Sep 07, 2012 11:50 am

Jvalov1 wrote:thanks, i ordered a pump last week so i'll see how it goes
What did you pay for it?
I have 3 in stock, leftover from my race spares.
Jvalov1
Posts: 18
Joined: Sun Mar 20, 2011 4:12 am
Location: California

Re: Fuel Pump Problem

Postby Jvalov1 » Fri Sep 07, 2012 9:00 pm

$200 bucks online was the cheapest i found. shipping and tax it totaled out to be $221
User avatar
BRP
Posts: 1925
Joined: Sat Sep 27, 2008 1:37 pm
Location: Southport, North Carolina

Re: Fuel Pump Problem

Postby BRP » Sat Sep 08, 2012 8:02 am

That's a good price, I could have matched it though.
They have really gone up since the last time I ordered.
I used to sell them for $180 in 2006.
Jvalov1
Posts: 18
Joined: Sun Mar 20, 2011 4:12 am
Location: California

Re: Fuel Pump Problem

Postby Jvalov1 » Fri Sep 21, 2012 7:53 pm

ya Steige got his for that much it sounds like. thanks though. installed it, runs better
steigs84
Posts: 117
Joined: Thu Oct 02, 2008 2:17 am
Location: Fort Worth, TX

Re: Fuel Pump Problem

Postby steigs84 » Sun Sep 23, 2012 12:42 am

After shipping, we are about the same, +/- $10.

Return to “Tech”

Who is online

Users browsing this forum: No registered users and 4 guests